總之這陣子在一些 legacy 專案上遇到需要修修改改的地方,然後沒人有空可以動了,所以就自己來…


一開始是遇到 bower 不能安裝,因為是公開的 GitHub repository ,用了修改自己的 .gitconfig 的方式,把 git@github.com: 改成 https://github.com/ 繞過。

這次是遇到 yarn 不能安裝,訊息只有 Permission denied (public key) ,而且因為是 private repository ,也沒辦法繞過,只好 stackoverflow 看看別人怎麼解。

在 yarn repository 也有人發了一樣的 issue, 日期甚至是 2017 年…

最後參考 2021 年有人貼的 GitHub troubleshooting 文件,重新產一把強度 4096 的 rsa key 之後,就可以正常 yarn install 了⋯

文章標籤

repeat :D 發表在 痞客邦 留言(0) 人氣()